[PATCH phonesim 3/7] configure.ac: use gnu++11 to fix build with Qt 5.7