On Thu, Feb 27, 2020 at 5:49 AM nick83ola <nick83ola@gmail.com> wrote:
Hi Anibal,
I was dragged in other things and I forgot to respond to you.
When I was in the US I had some issue with the network provider ->
they hadn't registered the sim for the right area where i was testing
it ->
so I couldn't test this patch thoroughly.

Hi Nicola,

One possible scenario could be that the Network provided settings (MCC, MNC) aren't in the mobile database information,
I have experience this with a SIM of a customer that uses a custom network settings.

Regards,
Anibal

 

If there's anyone there with a telit ME910C1 in the US could be very
helpful if we can test this through.
From what I've seen the modem is recognized and when I did the test
from remote with the right SIM it was working fine.
But I didn't test the auto-attach patch and now we switched for the
moment to another modem so I'm not in the condition of testing this.

Cheers
Nicola Lunghi


On Mon, 21 Oct 2019 at 13:45, nick83ola <nick83ola@gmail.com> wrote:
>
> Hi Anibal,
>
> Sorry but i was dragged along with other tasks and didn't test this througly.
> Next week I will be in the US (I am based in Ireland) to do some
> testing on the reliability of ME910
> and I will be able to thoroughly test this.
> For now (from remote) it seems to be working fine but next week I will
> have more information on this
>
> Thanks for your patience
> Nicola Lunghi
>
> On Thu, 3 Oct 2019 at 23:09, Anibal Limón <limon.anibal@gmail.com> wrote:
> >
> > Hi,
> >
> > I fix a bug in the code due to auto-attach, see [1] and the specific change [2].
> > Please test and let me know before send the patch.
> >
> > Cheers.
> > Anibal
> >
> > [1] https://github.com/alimon/ofono/tree/me910_fix_v2
> > [2] https://github.com/alimon/ofono/commit/682fd656afaf637b915d5d6b78a4211dd6e0884d
> >
> > On Wed, Oct 2, 2019 at 9:39 AM Anibal Limón <limon.anibal@gmail.com> wrote:
> >>
> >>
> >>
> >> On Wed, Oct 2, 2019 at 9:32 AM nick83ola <nick83ola@gmail.com> wrote:
> >>>
> >>> Thanks
> >>>
> >>> do you think that you can submit it to ofono mailing list?
> >>>
> >>> in particular I don;t know if
> >>>
> >>> if (data->model == ME910C1)
> >>> ofono_netreg_create(modem, OFONO_VENDOR_TELIT_ME910C1, "atmodem", data->chat);
> >>> else
> >>> ofono_netreg_create(modem, OFONO_VENDOR_TELIT, "atmodem", data->chat);
> >>
> >>
> >> That's because this specific model dosen't support  signal strength reporting via CIND.
> >>
> >> https://github.com/alimon/ofono/commit/920712e184ffaf1143e9ce13c3bec8ac1deeda5c#diff-2bbda16023120e26f58cfa7335520fb4
> >>
> >> Anibal
> >>
> >>>
> >>>
> >>> is acceptable
> >>>
> >>> Cheers
> >>> Nicola Lunghi
> >>>
> >>>
> >>> On Wed, 2 Oct 2019 at 15:29, Anibal Limón <limon.anibal@gmail.com> wrote:
> >>>>
> >>>>
> >>>>
> >>>> On Wed, Oct 2, 2019 at 9:00 AM nick83ola <nick83ola@gmail.com> wrote:
> >>>>>
> >>>>> Hi Anibal,
> >>>>> I'm interested as well in the patch
> >>>>>
> >>>>> I saw that there you have two branches (me910 and v1.30+me910) can you tell me what branch have you tested?
> >>>>> the diff is this
> >>>>
> >>>>
> >>>> Yeah the latest one is me910, I was making a mistake to enable GPRS instead of disable it, that's the change.
> >>>>
> >>>> Anibal
> >>>>
> >>>>>
> >>>>>
> >>>>> git diff me910
> >>>>> diff --git a/plugins/telit.c b/plugins/telit.c
> >>>>> index f36995dc..50344281 100644
> >>>>> --- a/plugins/telit.c
> >>>>> +++ b/plugins/telit.c
> >>>>> @@ -239,16 +239,19 @@ static void cfun_enable_cb(gboolean ok, GAtResult *result, gpointer user_data)
> >>>>>
> >>>>>         ofono_modem_set_powered(modem, TRUE);
> >>>>>
> >>>>> -       /*
> >>>>> -        * Tell the modem not to automatically initiate auto-attach
> >>>>> -        * proceedures on its own.
> >>>>> -        */
> >>>>> -       if (data->model == ME910C1)
> >>>>> -               g_at_chat_send(data->chat, "AT+CGATT=0", NULL, NULL, NULL, NULL);
> >>>>> -       else
> >>>>> -
> >>>>> +       if (data->model == ME910C1) {
> >>>>> +               /*
> >>>>> +                * Telit ME910C1 needs to activate the GPRS to auto-attach the network.
> >>>>> +                */
> >>>>> +               g_at_chat_send(data->chat, "AT+CGATT=1", NULL, NULL, NULL, NULL);
> >>>>> +       } else {
> >>>>> +               /*
> >>>>> +                * Tell the modem not to automatically initiate auto-attach
> >>>>> +                * proceedures on its own.
> >>>>> +                */
> >>>>>                 g_at_chat_send(data->chat, "AT#AUTOATT=0", none_prefix,
> >>>>>                                         NULL, NULL, NULL);
> >>>>> +       }
> >>>>>
> >>>>>         /* Follow sim state */
> >>>>>         g_at_chat_register(data->chat, "#QSS:", telit_qss_notify,
> >>>>>
> >>>>>
> >>>>> Thanks
> >>>>> Nicola Lunghi
> >>>>>
> >>>>>
> >>>>> On Tue, 1 Oct 2019 at 22:54, <limon.anibal@gmail.com> wrote:
> >>>>>>
> >>>>>> Hi Dresdo,
> >>>>>>
> >>>>>> I have a patch that adds support for Telit ME910 but it is upon Ofono 1.30, i plan to send for review.
> >>>>>>
> >>>>>> https://github.com/alimon/ofono/commit/920712e184ffaf1143e9ce13c3bec8ac1deeda5c
> >>>>>>
> >>>>>> Regards!,
> >>>>>> Anibal
> >>>>>> _______________________________________________
> >>>>>> ofono mailing list -- ofono@ofono.org
> >>>>>> To unsubscribe send an email to ofono-leave@ofono.org